Hosted Requirements

Hosted Requirements

SOFTWARE RECOMMENDED
Browser

Most recent version of any of the following:

  • Internet Explorer®
  • Google Chrome®
  • Firefox®
  • Apple® Safari® on Mac OS X
Browser Configuration
  • Your browser must be configured to allow cookies from *.juvare.com.
  • TLS 1.2 or higher must be enabled.
  • Your pop-up blocker must be configured to allow pop-ups from *.juvare.com.
  • Microsoft® Windows® users should consider making the Juvare domain (https://*.juvare.com) a trusted site. For Electronic ICS (eICS) users, making the domain a trusted site ensures you can take full advantage of eICS's integration with Microsoft Office®. For information on trusted sites, see the Microsoft Windows Help system.
Operating System
Windows 7® or later, Linux®, or Mac OS®
Reader
Adobe Reader® 9 or later
Additional Software

Microsoft Excel® 2007 or later

EMResource: To accommodate reports that can contain large amounts of data, EMResource generates reports in the .xlsx format. By default, Microsoft Excel 2007 or later is required to open .xlsx files. However, you can use older versions of Excel if you install the Microsoft compatibility pack (refer to the Microsoft website: http://www.microsoft.com/en-us/download/details.aspx?id=3).

HARDWARE MINIMUM
Monitor

Monitor with 1024x768 minimum resolution

Additional Hardware

Sound card with speakers (EMResource, eICS)

sound settings recommendations
EMResource, eICS
  • Your browser should be set to play sounds from web pages.
  • The volume on your computer must be set to an audible level so you can hear alerts or prompts.
network connection special considerations
Description
In addition to the normal network connection, we recommend that all users have the ability to use an alternate method to access the Internet in the event of an outage, such as a cellular or satellite provider.
Domain

When the Juvare solution is being accessed by a browser behind a firewall, the computer must have the ability to access the following domain:

https://*.juvare.com

network connection special considerations
Description
In addition to the normal network connection, we recommend that all users have the ability to use an alternate method to access the Internet in the event of an outage, such as a cellular or satellite provider.
Domain

When the Juvare solution is being accessed by a browser behind a firewall, the computer must have the ability to access the following domain:

https://*.juvare.com

proxy server settings
Description

Organizations use network proxy devices for one or both of the following reasons:

  • To control or limit their users’ access to certain websites from within the organization.
  • To optimize Internet traffic utilization by decreasing the actual retrieval of content from outside the organization.
Testing

Authorized users can gain access to eICS, EMResource, and EMTrack exclusively over port 443 (HTTPS protocol) and can access these solutions without issue through a minimally configured proxy server. However, each organization must test its network’s access through its customized proxy server. Without this level of testing, Juvare cannot guarantee that the experience with the sites will be completely unaffected when using the proxy servers.

Recommendations
Organizations that use proxy servers should configure them to bypass the proxy entirely for all *.juvare.com URLs. If this solution is not feasible, the organization could minimize issues by configuring the proxy to never cache content from these systems and to make as few alterations to the HTTP traffic as possible.
proxy server settings Recommended
Android
  • Android 8.0 or later
  • High-density screen of more than 200 dots per inch (dpi)
  • Multi-core processor of 4 or more cores

Juvare mobile applications are expected to be fully functional on any of the latest Android devices.

Sufficient testing on the following devices has been completed to certify full support:

  • Samsung Galaxy S series
  • Google Pixel series
  • 10" tablets for Fleeteyes MDT
iOS
  • iOS 11.0 or later
  • Some apps run on earlier iOS versions; see the iTunes Store for details
  • 5MP+ camera with auto-focus for scanning barcodes
iOS 12.0 or later